Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Nest driver disconnecting and reconnecting
#11
Well I was wrong it quit working again and now just dumped off.  I guess I will try and reconfigure the whole works with nest and see if that works.
Reply
#12
Is it the same error?
Dean Roddey
Software Geek Extraordinaire
Reply
#13
Yes it appears so:


Code:
11/27 17:25:48-DESKTOP-I0UM4J2, CQCIntfView, CQCMediaMDBCacher
{
   CQCMedia, CQCMedia_ThisFacility.cpp.2705, Failed/Internal
   An exception occurred in the media cache thread
}
11/27 17:25:48-DESKTOP-I0UM4J2, CQCIntfView, CIDOrbClientSpoolThread12
{
   CIDOrb, CIDOrb_ClientBaseHelpers.cpp.727, Failed/Lost Connection
   The server at 192.168.1.12:13502 has closed the connection
     <CQCIntfView> CIDOrbUC_NameSrvClientProxy.cpp - 115
     <CQCIntfView> CQCMedia_ThisFacility.cpp - 2713

}
11/27 17:25:48-DESKTOP-I0UM4J2, CQCIntfView, MainThread
{
   CQCIntfEng, CQCIntfEng_Overlay.cpp.2076, Failed/Cannot Do, Error: 6512/0/0
   Interface template '/User/Cable' could not be loaded. Reason=The server at 192.168.1.12:13502 has closed the connection
     <CQCIntfView> CQCIntfEng_ActEngine.cpp - 689
     <CQCIntfView> CQCIntfEng_View.cpp - 6049

}
11/27 19:14:06-DESKTOP-I0UM4J2, CQCAdmin, MainThread
{
   CQCKit, CQCAdmin_ThisFacility.cpp.154, Status/App Status
   CQCAdmin is starting up. Version=5.2.1
}
11/27 19:17:37-Office, CQCServer, CIDOrbSrvWorkThread_4
{
   CQCServer, CQCServer_DriverCtrl.cpp.202, Status/App Status
   A request to pause driver Nest was received, starting operation
}
11/27 19:18:13-Office, CQCServer, CIDOrbSrvWorkThread_1
{
   CQCServer, CQCServer_DriverCtrl.cpp.202, Status/App Status
   A request to resume driver Nest was received, starting operation
}
11/27 19:18:14-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3298, Status/App Status
   Driver 'Nest' is beginning initialization
}
11/27 19:18:14-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3445, Status/App Status
   Driver 'Nest' is trying to get its comm resource
}
11/27 19:18:14-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3484, Status/App Status
   Driver 'Nest' has its comm resource
}
11/27 19:18:14-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3502, Status/App Status
   Driver 'Nest' is trying to connect to its device
}
11/27 19:18:23-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3544, Status/App Status
   Driver 'Nest' has connected to its device
}
11/27 19:18:46-Office, CQCServer, CQCDrv_NestThread12
{
   CQCGenDrvS, MEng.System.CQC.Drivers.Nest.Cloud.DriverImpl.964, Status/App Status
   Poll failure. Error=Got an incomplete encrypted packet. Name=Secure Client Data Source
}
11/27 19:18:46-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.7255, Status/Lost Connection
   Driver 'Nest' has lost connection to it's device
}
11/27 19:18:46-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.7289, Status/Lost Connection
   Driver 'Nest' has lost its communcations resource
}
11/27 19:18:51-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3445, Status/App Status
   Driver 'Nest' is trying to get its comm resource
}
11/27 19:18:51-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3484, Status/App Status
   Driver 'Nest' has its comm resource
}
11/27 19:18:51-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3502, Status/App Status
   Driver 'Nest' is trying to connect to its device
}
11/27 19:19:00-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3544, Status/App Status
   Driver 'Nest' has connected to its device
}
11/27 19:19:47-Office, CQCServer, CQCDrv_NestThread12
{
   CQCGenDrvS, MEng.System.CQC.Drivers.Nest.Cloud.DriverImpl.964, Status/App Status
   Poll failure. Error=Got an incomplete encrypted packet. Name=Secure Client Data Source
}
11/27 19:19:47-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.7255, Status/Lost Connection
   Driver 'Nest' has lost connection to it's device
}
11/27 19:19:47-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.7289, Status/Lost Connection
   Driver 'Nest' has lost its communcations resource
}
11/27 19:19:48-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.7234, Failed/Lost Connection, Error: 906/0/0
   Driver 'Nest' is not currently connected to its device
     <CQCServer> CIDOrb_ThisFacility.cpp - 536
     <CQCIntfView> CQCKit_CQCSrvAdminClientProxy.cpp - 1945
     <CQCIntfView> CQCAct_StdCmdTargets.cpp - 268

}
11/27 19:19:48-DESKTOP-I0UM4J2, CQCIntfView, CQCRunActionThread5
{
   CQCAct, CQCAct_StdCmdTargets.cpp.275, Failed/App Status
   Failed to write to field Nest.THERM#Hallway~LowSetPnt
   67
}
11/27 19:19:52-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3445, Status/App Status
   Driver 'Nest' is trying to get its comm resource
}
11/27 19:19:52-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3484, Status/App Status
   Driver 'Nest' has its comm resource
}
11/27 19:19:52-Office, CQCServer, CQCDrv_NestThread12
{
   CQCKit, CQCDriver_DriverBase.cpp.3502, Status/App Status
   Driver 'Nest' is trying to connect to its device
}
Reply
#14
That's the same error as before. There's something weird going on with the encrypted connection it seems like. The only thing on our end that's related to that is the generated access token that you give the driver. So it would be worth generating a new one and doing a reconfigure on the driver to use it.
Dean Roddey
Software Geek Extraordinaire
Reply
#15
ok I deleted the driver and reinstalled it with new pin and token. still disconnecting and reconnecting each time I make a temperature change. It recovers after about 15 seconds so maybe this is normal?
Reply
#16
It's not normal definitely. AFAIK, no one else is seeing that. Is it just a temp change, or is there anything else that is causing it? Maybe we just need to have the driver back off more after a temp change or something.
Dean Roddey
Software Geek Extraordinaire
Reply
#17
(11-28-2017, 07:51 PM)Dean Roddey Wrote: It's not normal definitely. AFAIK, no one else is seeing that. Is it just a temp change, or is there anything else that is causing it? Maybe we just need to have the driver back off more after a temp change or something.

it seems stable if I dont touch it Smile .  Yes only a temp change knocks it off line either by direct temp change via cqc or by nest android app on phone.
Reply
#18
Do you have anything tied to a temp change on the Nest side of things? Something that might make it goes off and think for longer than normal?
Dean Roddey
Software Geek Extraordinaire
Reply
#19
not that I am aware of no. I had a very simple iv that displays current temp and current temp settings and humidity . No automation logic tied to any of the fields other than that. Just use a field slider to change temp.
Reply
#20
That slider isn't sending changes as you drag it is it? That would be way too fast and overwhelm the driver. You really can only send the change when you release. You can use a local display that you make visible to show the current drag value so that you know what it will be when you release it, then hide it upon release.
Dean Roddey
Software Geek Extraordinaire
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  New Z-Wave driver preview Dean Roddey 14 1,091 06-22-2018, 07:02 PM
Last Post: Dean Roddey
  RCS V2 Driver kblagron 2 82 06-10-2018, 04:35 PM
Last Post: Dean Roddey
  Redid server, issues with Nest and Elk ghurty 6 183 05-16-2018, 05:15 PM
Last Post: Dean Roddey
  Sonos Driver with Sonos Connect Amp zra 5 285 05-05-2018, 09:43 AM
Last Post: Dean Roddey
  Radio RA driver issue dogman 7 389 04-22-2018, 08:33 AM
Last Post: Dean Roddey
  Helios vs Nest Hello ewiz 3 355 04-01-2018, 02:07 PM
Last Post: Dean Roddey
  Elk Driver fails Ron Haley 11 720 03-08-2018, 07:28 PM
Last Post: Ron Haley
  Aeotec USB stick, existing zWave (v3) driver? IVB 3 318 03-05-2018, 08:57 PM
Last Post: znelbok
  Problem with Jetstream Driver RichardU 16 1,104 02-27-2018, 03:05 PM
Last Post: batwater
  Problem with fooBarV2 driver pjgregory 2 377 02-21-2018, 01:01 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 2 Guest(s)