Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
System Config
#31
C:\Users\Spa Pool\AppData\Roaming>set CQC
CQC_DATADIR=C:\Program Files (x86)\CQC\CQCData
cqc_password=9630
CQC_SYSTEMID=0A25184839C4D659-E089B5F964AD2BCA
cqc_username=Admin

C:\Users\Spa Pool\AppData\Roaming>
Reply
#32
OK, so this error:

Code:
01/10 10:15:35-Officecomputer, CQCServer, CQCDrv_LitesThread9
{
  CIDLib, CIDLib_FileBase.cpp.352, Failed/Cannot Do, Error: 1414/625/3
  Could not open the file, name=C:\Program Files (x86)\CQC\CQCData\MacroFileRoot\Drivers\RadioRA2\Lites.Cfg
  The system cannot find the path specified.
  <CQCServer> CIDLib_BinaryFileStream.cpp - 355
  <CQCServer> CIDMacroEng_OutputStreamClasses.cpp - 1262
}

Is happening when the driver tries to save the file. It's operating system error 3, which is path not found. That means it couldn't write the file because the path that it's trying to write to doesn't exist. Not that the file doesn't exist, which wouldn't matter, because it's trying to create it, it's that the path the file is being written to doesn't. So, if you look in:

C:\Program Files (x86)\CQC\CQCData\MacroFileRoot\

is there a Drivers subdirectory? And inside that is there a RadioRA2 directory? If not, create them, flush the logs and try the above again.

I'm guessing that's it in this case. Originally you had to create the file by hand, so you had to have created those directories yourself. When I added the client side driver, I didn't add the code to make sure those paths were created. For all existing users, they would have already had the file there that they created themselves, so this wouldn't have affected them, and that's why I didn't catch it either on my system. The directories already existed.

So, for the moment just create them and it should work. But, after that, you shouldn't have any issues, at least on that machine. If you move it somewhere else, you'll have to make sure they exist there as well, at least until the next drop. I'll update the driver for the next drop to make sure those paths are created.
Dean Roddey
Software Geek Extraordinaire
Reply
#33
A failure to store the file was also not being correctly propagated back to the client side driver, so it didn't warn you when it failed to store the info. That's been fixed as well. That also let the AI think that the changes had been successfully stored, so any subsequent save wouldn't do anything until you made a change. So even if you went and created the directory after that and saved again, it wouldn't save it if there were now changes. So now if it fails you'll get an error and you'll still have the outstanding changes to save (and a warning when you try to close the tab to let you know that.)

Oh well, it's a brand new client side driver scheme, so these quirks are not unexpected I guess.
Dean Roddey
Software Geek Extraordinaire
Reply
#34
Did creating the directory make it happy?
Dean Roddey
Software Geek Extraordinaire
Reply
#35
Haven't had a chance to mess with it yet, should be able to this weekend.
Thanks
Reply
#36
I've already posted a new version (5.2.9) in which the driver correctly creates the directories if they don't exist.
Dean Roddey
Software Geek Extraordinaire
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  New HVAC System - Nest? dgage 5 1,445 05-24-2017, 11:15 AM
Last Post: dgage
  Keep system from sleeping George M 8 2,200 01-20-2017, 06:37 PM
Last Post: wuench
  Auto Gen / Room config potts.mike 3 1,485 12-28-2016, 06:51 PM
Last Post: Dean Roddey
  Porting Auto-Gen Music Templates to Existing System TurboSam 4 1,090 08-31-2016, 01:08 PM
Last Post: TurboSam
  Need help to get a working system on CQC ellisr63 26 4,510 10-19-2015, 05:05 AM
Last Post: jkmonroe
  Philips Hue group config pinballmark 8 1,828 07-27-2015, 05:19 PM
Last Post: jkmonroe
  Kiosk Error: "No CQC System ID was set" TurboSam 3 1,381 07-26-2015, 01:16 PM
Last Post: TurboSam
  System crashed, unable to get it going again. Deane Johnson 43 5,442 11-11-2014, 04:50 AM
Last Post: Mark Stega
  CQC Webserver config lleo 2 1,187 10-04-2014, 12:06 PM
Last Post: lleo
  Replacement HVAC system pinballmark 6 3,154 11-18-2013, 07:48 PM
Last Post: dgage

Forum Jump:


Users browsing this thread: 1 Guest(s)