Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Venstar Thermostat keeps disconnecting then reconnecting
#1
I seem to be having a problem with the venstar thermostat driver. I have two thermostats, one voyager (thermostat_downstairs) and one color touch(thermostat_upstairs). I have them both loaded in CQC version 5.2.1. This evening the Thermostat_upstairs won't stay connected for more than a 10 seconds and then disconnects and keeps trying to reconnect, the downstairs_thermostat will stay connected and periodically disconnect but is able to reestablish its connection(It goes through that cycle about once every 5 minutes). I am not sure why either driver can't keep its connection. The error log shows that
Code:
CQCKit, MEng.System.CQC.Drivers.Venstar.ColorTouch.DriverImpl.206, Status/App Status
   HTTP GET failed. URL=, Err=Connect operation failed. Tried to connect to: 10.0.0.26:80. The provided value was invalid
but I am able to load that address in my web browser repeatable with no problems.

Any help would be appreciated.

Adam


Attached Files
.txt   thermostat error log.txt (Size: 14.96 KB / Downloads: 1)
Reply
#2
Unfortunately the code logging the error is not correct. It's showing an empty URL because it's logging the wrong thing. I've attached another one for you to try so that we can see what the actual URL is. 

Import this package, then do a reconfigure on the driver (at least the one that's failing the one wouldn't matter) and get another log dump after it's run for 30 seconds or so. Let's see what the URL is. The error is from the actual GET operation, and it's a GET so the URL is the only thing involved. So presumably it has to be the URL that's the issue.


Attached Files
.cqcdrvpack   VenstarThermoLogMsgFix.CQCDrvPack (Size: 8.01 KB / Downloads: 1)
Dean Roddey
Software Geek Extraordinaire
Reply
#3
Here is the updated log file. I also reset power to the thermostats and that seems to have cut down on the driver disconnects but they seem to still randomly disconnect.


Attached Files
.txt   thermo-logs.txt (Size: 8.26 KB / Downloads: 1)
Reply
#4
Try the attached driver pack. I've lowered the frequency of polling and extended the timeout. Let's see if that makes it happier. Import the driver pack then do a reconfigure on the driver to pick up the changes.


Attached Files
.cqcdrvpack   VenstarThermoLongerTimeout.CQCDrvPack (Size: 8.01 KB / Downloads: 1)
Dean Roddey
Software Geek Extraordinaire
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  RCS Thermostat Driver help sic0048 10 895 08-19-2017, 08:01 AM
Last Post: Dean Roddey
  Nest Thermostat Template dogman 0 418 02-18-2017, 09:49 AM
Last Post: dogman
  Is there a driver out there for the Honeywell Wi-Fi Smart Thermostat? ghurty 9 2,681 06-13-2015, 04:50 PM
Last Post: Dean Roddey
  RCS Zigbee (Xbee) Thermostat Driver issue Bugman 5 884 02-16-2015, 03:37 PM
Last Post: Dean Roddey
  Issues with Jandy Driver Disconnecting avtexan 1 794 10-29-2014, 06:10 PM
Last Post: Dean Roddey
  Where is the thermostat when configuring a room? ghurty 5 843 05-07-2014, 06:16 AM
Last Post: Dean Roddey
  RadioRa2 Thermostat Support - Donation? dgage 40 5,696 02-05-2014, 10:48 AM
Last Post: dgage
  Venstar Thermostat SP fields Squiddy 7 710 09-15-2012, 06:23 PM
Last Post: Squiddy
  Elk Driver Disconnecting jrunde 4 585 10-27-2009, 06:09 PM
Last Post: jrunde
  Adding some "smarts" to my dumb thermostat beelzerob 10 1,585 04-28-2009, 05:20 AM
Last Post: beelzerob

Forum Jump:


Users browsing this thread: 1 Guest(s)