Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Monoprice Blackbird 4x4 HDMI Switcher - Driver request
#11
Hey Dean, there's something amiss with the driver for the Monoprice Blackbird 4x4 HDMI Switcher. If the driver is in a wait for comm resource state and you pause it (either IP or serial) the following occurs:

1) Admin interface stays red
2) Admin GUI right click on driver shows that the driver is paused
3) Driver tab Driver Status field continues to continues to cycle between "Wait for Connect" and "Wait for Comm Resource"

Right now the HDMI switch is locked up for some reason and I need to go power cycle it but I'm thinking that regardless of the device state the driver in the admin interface should not behave this way...
Reply
#12
I dunno, that sounds reasonable. #3 isn't optimal but it sometimes happens if the driver gets connected, then something fails to work, and it just goes all the way back to wait for comm resource. For a serial driver, usually just going back to trying to reconnect is sufficient, then it just stays in Wait for Connect state.

BTW, I have done some work on that guy, just a few days ago but haven't posted it. Kristian got an 8x8 one. The current driver is hard coded to 4x4 since I never had anything else to test with. So I expanded it out to be able to select an 8x8 model. But, then he figured out he had one of the ones that has the Fred Flintstone version of the control protocol so I never ended up being able to test it anyway.

If you want to open yours up I can make sure that these changes still work right against the 4x4. I also made some small improvements as well, which might help your setup. I can also look at the #3 scenario above while I have one to test against.
Dean Roddey
Software Geek Extraordinaire
Reply
#13
Okay, all set up, emailed connection info to you. BTW, the IP driver is doing the same cycling as the serial port driver. Also, once the unit power cycled the GUI changed to black instead of grey but the status was paused. Resuming and then pausing again gets it back correct.
Reply
#14
It being offline must have interfered with the pause/resume command in some way. I sent you a new version.
Dean Roddey
Software Geek Extraordinaire
Reply
#15
Installed. Everything seems okay so far...
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  LIFX Driver bobskie708 12 2,124 11-26-2018, 05:23 PM
Last Post: Dean Roddey
  Driver for Bigass Fan lleo 7 211 11-25-2018, 08:57 AM
Last Post: Dean Roddey
  Amazon Echo Hue Simulator Driver wuench 115 41,859 11-08-2018, 06:49 AM
Last Post: karenlee
  RunTimer2 driver rbroders 14 4,168 10-15-2018, 11:45 AM
Last Post: rbroders
  Generic Modbus Driver - Serial & IP znelbok 25 12,594 10-09-2018, 08:59 AM
Last Post: Ron Haley
  Issues debugging IP based driver jnolting 5 554 09-24-2018, 11:52 AM
Last Post: Dean Roddey
  Enhance Driver Test Harness Field Monitor rbroders 1 317 09-24-2018, 10:49 AM
Last Post: Dean Roddey
  Koyo Click PLC Driver rbroders 75 29,047 09-23-2018, 01:18 PM
Last Post: rbroders
  Carrier Infinity HVAC Driver beelzerob 34 13,938 09-07-2018, 01:15 PM
Last Post: lleo
  Sony TV IP driver dogman 10 1,334 08-01-2018, 03:53 PM
Last Post: znelbok

Forum Jump:


Users browsing this thread: 1 Guest(s)