Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lutron Caseta & Zwave Issues
#1
I have two problems that hopefully someone can help me with.  I assume they are easy fixes and I am missing something simple.

First problem: I installed a new, clean copy of version 5.1.2 on a new computer.  I had been running 4.7 until the computer got wiped.  With the new install I can't open the client driver for zwave (non-vrcop).  Hoping to phase it out, but until then would like to get it working.  Before upgrade everything worked great.  Also, driver loads and connects fine.  Tried the tips in the Official Beta 5.2 thread, but so far no luck.  The error I get is:

06/22 22:35:55-CQCserver, CQCDataSrv, CIDOrbSrvWorkThread_1
{
    CQCDataSrv, CQCDataSrv_InstServerImpl.cpp.1468, Failed/Not Found, Error: 3200/0/0
    Facility 'ZWaveUSBC' was not found. Version=5.1
      <CQCDataSrv> CIDOrb_ThisFacility.cpp - 536
      <CQCAdmin> CQCKit_InstClientProxy.cpp - 545
      <CQCAdmin> CQCAdmin_ClientDrvTab.cpp - 114
}


Second problem is trying to get my new Lutron Caseta to connect.  So far no luck.  I added the text config file, entered IP address, username & password.  The android app for it on my phone works fine.  It is the Smart Bridge Pro.
06/22 22:14:54-CQCserver, CQCServer, CQCDrv_CasetaThread16
{
    CQCKit, CQCDriver_DriverBase.cpp.3445, Status/App Status
    Driver 'Caseta' is trying to get its comm resource
}
06/22 22:14:54-CQCserver, CQCServer, CQCDrv_CasetaThread16
{
    CQCKit, CQCDriver_DriverBase.cpp.3484, Status/App Status
    Driver 'Caseta' has its comm resource
}
06/22 22:14:54-CQCserver, CQCServer, CQCDrv_CasetaThread16
{
    CQCKit, CQCDriver_DriverBase.cpp.3502, Status/App Status
    Driver 'Caseta' is trying to connect to its device
}
06/22 22:14:57-CQCserver, CQCServer, CQCDrv_CasetaThread16
{
    CQCGenDrvS, MEng.System.CQC.Drivers.Lutron.RadioRA2.DriverImpl.1937, Status/App Status
    Exception in connect. Err=Timed out waiting for msg type Monitoring from ID 3
}
06/22 22:14:57-CQCserver, CQCServer, CQCDrv_CasetaThread16
{
    CQCKit, CQCDriver_DriverBase.cpp.7289, Status/Lost Connection
    Driver 'Caseta' has lost its communcations resource
}

Any help is appreciated, thanks.
Pat
Reply
#2
I haven't tried the old USB stick driver in a while, so maybe it got whacked somehow. I'll try it and see what is going on.

On the Caseta you might have to open it up for me so that I can see what is going on. The same protocol is supposed to work for it and RA2, but there may be some small differences that need to be accounted for. If you can port forward it for me, I can take a look. I assume it has a username/password like RA2? If so you'll need to send me that. You can change them after I'm done.
Dean Roddey
Software Geek Extraordinaire
Reply
#3
OK, it's not there because I didn't port it. Like all of the client drivers it was going to require a lot of work to convert, and I didn't even know if anyone was even using this driver anymore. So I just left it out. I'll see what it'll take to convert it over.
Dean Roddey
Software Geek Extraordinaire
Reply
#4
I've got it compiling, though I had to hack quite a bit and it's been a while since I've done one of these 4.x to 5.x GUI conversions so I've probably introduced lots of bugs. So I'll have to get this setup going again and test it out. I've stripped it down to just what's needed. No group editing, no config parameter setting, just the management of the units.
Dean Roddey
Software Geek Extraordinaire
Reply
#5
Well, I'm kind of stuck on the USB Z-Wave driver. My only master controller is the Vizia RF which uses the USB stick. So I can't initialize the USB stick as a secondary and copy over the network because it has to be in use by the master controller in order to do that. I'd have to get a second USB stick to make it work.
Dean Roddey
Software Geek Extraordinaire
Reply
#6
Nevermind I found an ancient HA07 hardware controller I can use for this.
Dean Roddey
Software Geek Extraordinaire
Reply
#7
OK, I got that set up, but I'm at a bit of a loss on using the VRUSB. It needs to show up as a serial port, but it just shows up as an HID USB device. I don't see any driver available for it to make it look like a serial port right off hand, though I think that's how it was done. I'm on Windows 10 so maybe that has something to do with it.
Dean Roddey
Software Geek Extraordinaire
Reply
#8
I'm slowly figuring out the Caseta. It has some quirks and limitations relative to the RA2. I've set up a separate manifest for the Caseta (still pointing to the RA2 driver) and added fixed driver prompts to the manifests to tell the driver which device it's talking to so it can adjust.

The thing that killed me was that it takes up to 15 seconds to present the login prompt after you connect. I was giving up long before that, thinking it wasn't responding.

It looks like it doesn't accept the monitoring enable/disable commands, and just has those async reporting flags set permanently, so I'll not send those if in Caseta mode.

And it looks like you can't make it turn off the telnet prompt either, which is a pain, since I'll have to parse that out of everything.
Dean Roddey
Software Geek Extraordinaire
Reply
#9
I have what seems to be a working Caseta driver. I need to check that I've not broken it for RA2, but it should be clean. The differences were annoying but not terrible, at least for the devices I've seen so far. Probably won't be any problems for the others since all of the device interaction stuff seems the same.
Dean Roddey
Software Geek Extraordinaire
Reply
#10
OK, I took care of a few small things I'd broken on the RA2 side, and sent Pat the Caseta driver to test, but it should be fine. So we have Caseta support now.
Dean Roddey
Software Geek Extraordinaire
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Cover Art Browser scrolling issues sic0048 7 367 08-22-2017, 08:00 PM
Last Post: Dean Roddey
  Incorporating zWave devices kjaerligkatt 4 507 08-14-2017, 08:56 AM
Last Post: kjaerligkatt
  Lutron Caseta and T-Stats bryanb 4 218 07-31-2017, 08:27 AM
Last Post: bryanb
  Repo issues IVB 6 634 05-17-2017, 10:14 PM
Last Post: IVB
  1024 x 768 issues DaveB 8 628 04-15-2017, 08:37 AM
Last Post: Dean Roddey
  5.0 upgrade issues dlmorgan999 61 5,061 04-11-2017, 01:20 PM
Last Post: Dean Roddey
  Zwave - FIBARO Door/Window Sensor + Temp batwater 5 631 03-18-2017, 02:16 PM
Last Post: Dean Roddey
  ISY and Zwave potts.mike 20 2,006 03-02-2017, 12:55 PM
Last Post: Dean Roddey
  Can CQC work with Lutron or Vantage? ghurty 1 415 02-19-2017, 04:03 PM
Last Post: Dean Roddey
  Telnet and Caseta tom 7 918 01-25-2017, 05:18 PM
Last Post: tom

Forum Jump:


Users browsing this thread: 1 Guest(s)