Charmed Quark Systems, Ltd. - Support Forums and Community
Android RIVA Client: taRiva - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forum)
+-- Forum: Third Party Development (https://www.charmedquark.com/vb_forum/forumdisplay.php?fid=8)
+--- Forum: Android Related Products (https://www.charmedquark.com/vb_forum/forumdisplay.php?fid=24)
+--- Thread: Android RIVA Client: taRiva (/showthread.php?tid=6721)



Android RIVA Client: taRiva - joeberg - 09-09-2012

kayemsi Wrote:Yeah, the title bar shows up after restart. After restart the title came up, but apparently it was just the act of switching that got the whole template to load and the spin to stop, because after restarting I am back to spinning indicator and partially loaded non responsive screen. I have to hit back (quit) several times to get to the point it will listen to the setting menu, then if I toggle the hide title, then it will suddenly load the whole template, but now it is still spinning and non-responsive.

I am getting the same behavior on my Droid Razr Max. Sometimes it works ok to start and then degrades to this behavior as I switch through some screens and test.

Joe


Android RIVA Client: taRiva - Fonceur - 09-09-2012

Are the issues on new Android 4.x phones only? I'm getting the feeling that some things are now getting multi-threaded, which were not before... Wink


Android RIVA Client: taRiva - RichardU - 09-09-2012

My problem is with 4.1.


Android RIVA Client: taRiva - kayemsi - 09-09-2012

The Bionic, which is Gingerbread works much better than the S3, ICS, which is basically unusable. This is after the upgrade from 4.0.10 to 4.2.5, now 4.2.6. I posted some of the errors that the CQC riva server sees over under CQC Support, 4.2.4 thread. The S3 was working OK, or much better anyway, before the CQC upgrade.


Android RIVA Client: taRiva - Dean Roddey - 09-09-2012

I think he meant the OS version on the phones, not the CQC version, right?


Android RIVA Client: taRiva - Fonceur - 09-09-2012

Version 1.10

- Replaced "Hide title bar" by the safer "Full screen mode".
- Toggle the "Full screen mode" without restart.
- Moved the Activity indicator to the title bar.
- Set the debug flag to true.


This is not meant to be a definitive answer to the current issue(s), so I'm not going to have it posted to Google Play or Amazon just yet...

It is only available through the dropbox download link of the version which requires registration...


Android RIVA Client: taRiva - Fonceur - 09-10-2012

Version 1.11

- Fix: Eliminated the possibility of multiple active clients.


I still have more to fix, but I think this version will work better. Not pushing this one to Google Play/Amazon just yet either...


Android RIVA Client: taRiva - Fonceur - 09-10-2012

Version 1.12

- Removed some delays in processing messages.


Android RIVA Client: taRiva - batwater - 09-16-2012

Hi Fonceur,

Here is a status update on taRiva behavior, it's still not right...

This is tested on CQC 4.2.9 and there are no errors in the CQC log.

I can start a client once, when I exit cleanly I cannot get back in for some period of time or until I reboot the phone, all I get is a spinning progress indicator. I have not validated how long long is before I can restart the client successfully. I did try a 10 second delay between exiting the application cleanly and starting it back up again.

I have tried this test on v1.09 (current in market) on one phone and 1.12 on my other phone. Both phones are at 4.04 of Android.

I have emailed separately a log dump from the phone running the 1.12 code level.

Thanks for looking at this!
-Ben


Android RIVA Client: taRiva - sic0048 - 09-16-2012

I saw Batwater's post, so I tried it myself because I had not noticed this behavior myself.

I updated to 1.12 and started CQC. It is connecting over my wi-fi network. The first time I closed out. I went back into the recently used apps and selected TaRiva and it started just fine. But after that first occurance, if I exit out of the app and restart it (either via the recent button or the app draw), I only get a black screen. When I pull up the information menu, it has the correct template listed. I'm not sure if that only shows when connected, or if that info is alway there.

I can force close the app via the settings/applications area. I can select the TaRiva app from "All Apps" and force close it. After doing that, I can restart the Riva program and it will load normally again, but only once - I'm not sure what might have been different that first time I tried this.

So I just wanted to confirm that Batwater isn't the only person seeing this behavior. As I started out saying, I haven't noticed this behavior before, but I wasn't specifically looking for it either.