Charmed Quark Systems, Ltd. - Support Forums and Community
Android RIVA Client: taRiva - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forum)
+-- Forum: Third Party Development (https://www.charmedquark.com/vb_forum/forumdisplay.php?fid=8)
+--- Forum: Android Related Products (https://www.charmedquark.com/vb_forum/forumdisplay.php?fid=24)
+--- Thread: Android RIVA Client: taRiva (/showthread.php?tid=6721)



Android RIVA Client: taRiva - Fonceur - 09-12-2010

Version 0.53

- Fix: Was not handling the Pop...
- Re-enabled all clipping.


Android RIVA Client: taRiva - sic0048 - 09-13-2010

What type of images should we see now?

Here is a screen shot of your new mobile templates. None of the images show up and the text appears slightly fuzzy.

[Image: CAP201009131709.jpg]


Android RIVA Client: taRiva - Fonceur - 09-13-2010

sic0048 Wrote:What type of images should we see now?
This is using taRIVA .53? I guess the images were too big for your connection speed. If you switch to a different day and back, you should see them...

For the ???, it just means you didn't load/setup the variable driver. As for the fuzzy text, I guess Android doesn't scale fonts properly for all sizes...


Android RIVA Client: taRiva - Fonceur - 09-14-2010

I think most of the elements are in, so it is now possible to buy a registration key for $19.99. Of course there are still more iterations to come...

Just a heads up, some of the features will be moved to the "registered only" version...


Android RIVA Client: taRiva - sic0048 - 09-14-2010

Purchased!

On another note, I deleted the user profile that I had stored in the RIVA client and now the application force closes anytime I try to open it. I assume it is because it is trying to connect, yet there is no server information stored.

I deleted the profile because I lost the ability to connect. I tried both using a LAN setup as well as over 3g and nothing would work. The odd thing is that nothing changed. I didn't change versions and I tried using both your templates and my old template without luck. The screen would just it there on the CQC initial page. There was a thread error in the CQC log, but no details.

Checking the phone log I see an entry that says "W/System.err(10987):java.net.SocketException: Broken Pipe as well as some other stuff. I'm going to send you an email of the log.


Android RIVA Client: taRiva - SamVimes2 - 09-14-2010

Hi Fonceur,

Any thoughts on the issue above where some devices' resolutions are being misreported? I'd love to buy and use the app!

Thanks.


Android RIVA Client: taRiva - Fonceur - 09-14-2010

sic0048 Wrote:On another note, I deleted the user profile that I had stored in the RIVA client and now the application force closes anytime I try to open it.
Actually, if you delete the first item I can see a problem... Fixing that for .54.

Quote:I tried both using a LAN setup as well as over 3g and nothing would work.
The last time something similar was reported, it was due to the user turning off wifi or such...


Android RIVA Client: taRiva - Fonceur - 09-14-2010

SamVimes2 Wrote:Any thoughts on the issue above where some devices' resolutions are being misreported?
I will need to add some more debugging text and use multiple ways of querying the resolution... In the mean time, what is the maker/version of your phone?


Android RIVA Client: taRiva - sic0048 - 09-14-2010

Fonceur Wrote:The last time something similar was reported, it was due to the user turning off wifi or such...

I've tried it both ways. It is strange that it was working fine at one point yesterday and I was able to take the screen shots above, and then later that day, it won't connect. I tried both the "Home" LAN setup over the wireless network, and the "Away" setup which points to a dynamic DNS server which works over 3G or wireless. I'm hoping the logs show something because the CQC log shows the connection trying to be made, but some error causes it to stop.

I haven't tried the windows version of the RIVA client in a week or so, but I was having issues with it connecting too. Oddly enough, my iPaqs connect just fine without any issues. I'll try the Windows version again ASAP, but it might be a couple days.


Android RIVA Client: taRiva - Fonceur - 09-14-2010

SamVimes2 Wrote:Any thoughts on the issue above where some devices' resolutions are being misreported?
As a data point, sic0048's DroidX which is advertised as 480 x 854 is being reported as 320 X 569 by my detection method...