Charmed Quark Systems, Ltd. - Support Forums and Community
Official 5.4 Beta Discussion Thread - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forum)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forum/forumdisplay.php?fid=3)
+--- Forum: Beta Discussions (https://www.charmedquark.com/vb_forum/forumdisplay.php?fid=12)
+--- Thread: Official 5.4 Beta Discussion Thread (/showthread.php?tid=10623)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22


Official 5.4 Beta Discussion Thread - Dean Roddey - 07-05-2018

5.3 is out, so any discussions now should be in the context of the 5.4 release. Though of course some of the things that might come up here may be addressed in some 5.4.x followup releases. More to follow, just getting the new threads created and the old ones closed and unstuck.


RE: Official 5.4 Beta Discussion Thread - batwater - 07-05-2018

Okay, I managed to get one of the Linear WADWAZ-1 door units to get properly configured but the driver is not picking up the values properly from the device and showing ??? instead of filling the fields in.

Steps:

1) follow my published VRC0P manual association method to associate WADWAZ-1 to Aeon Stick.
2) Pause the CQC driver
3) Fire up Zentools and trigger a replication (include/exclude button (replication) from CQC does not work)
4) start CQC driver
5) in client side driver enable the device by rescanning the device (I disabled all battery devices not properly working)
6) wake the device up
7) approve device

Here's the trace of me opening and closing the door sensor:

Z-Wave USB3 Trace
, Time: 10:07:53 AM
----------------------------------------------------

10:08:01 - [ZW->DR] - REQ,Msg:AppCmd/0x4,Recvd: 10:08:01)
{
Flags:
Type: Single
SrcId: 3
Class: Basic
Cmd: Set
Bytes: 00 03 03 20 01 FF
}
10:08:01 - [TRACE]- Processing app cmd. Src=3, Class=20, Cmd=1
10:08:10 - [ZW->DR] - REQ,Msg:AppCmd/0x4,Recvd: 10:08:10) 9498MSs
{
Flags:
Type: Single
SrcId: 3
Class: Basic
Cmd: Set
Bytes: 00 03 03 20 01 00
}
10:08:10 - [TRACE]- Processing app cmd. Src=3, Class=20, Cmd=1


RE: Official 5.4 Beta Discussion Thread - batwater - 07-05-2018

The WADWAZ-1 is the type I tried to set manually and it didn't work. Data fields don't update after being approved.


RE: Official 5.4 Beta Discussion Thread - batwater - 07-05-2018

Dean, your comment about the save in the Save doesn't hold water (responding to this post), you provide a save button in the edit window, what's the purpose if not to save?  Requiring a second save doesn't make sense.


CQC Admin Interface -> Customize -> Events -> Triggered -> User -> <event>

This is where the edit window got messed up after resizing. (this post)


RE: Official 5.4 Beta Discussion Thread - batwater - 07-05-2018

Did you catch this post with the repeating almost to infinity (probably somewhat matches the # of devices I have in my zwave network) dialog box error when loading the zwave driver for the first time?


RE: Official 5.4 Beta Discussion Thread - Dean Roddey - 07-05-2018

(07-05-2018, 03:20 PM)batwater Wrote: Okay, I managed to get one of the Linear WADWAZ-1 door units to get properly configured but the driver is not picking up the values properly from the device and showing ??? instead of filling the fields in.

10:08:01 - [ZW->DR] - REQ,Msg:AppCmd/0x4,Recvd: 10:08:01)
{
Flags:
Type: Single
SrcId: 3
Class: Basic
Cmd: Set
Bytes: 00 03 03 20 01 FF
}

OK, the problem is that it isn't sending what I expected it to. It's sending a Basic Set, when I expected it to send a notification. I'll get that fixed.


RE: Official 5.4 Beta Discussion Thread - Dean Roddey - 07-05-2018

(07-05-2018, 03:30 PM)batwater Wrote: Dean, your comment about the save in the Save doesn't hold water (responding to this post), you provide a save button in the edit window, what's the purpose if not to save?  Requiring a second save doesn't make sense.


CQC Admin Interface -> Customize -> Events -> Triggered -> User -> <event>

This is where the edit window got messed up after resizing. (this post)

That's not going to change. It's fundamentally at odds with how everything else works. The action isn't the whole thing. You are only keeping the changes to that part of the thing you are editing. We don't save the template when you hit save on the states dialog or anything like that. This is no different. It's just part of the thing, and you are just putting those changes into the larger thing you are editing. If you cancel, then none of those changes go back to the tab, but we don't close it because you might have other changes. So it's completely consistent.


RE: Official 5.4 Beta Discussion Thread - Dean Roddey - 07-05-2018

(07-05-2018, 03:49 PM)batwater Wrote: Did you catch this post with the repeating almost to infinity (probably somewhat matches the # of devices I have in my zwave network) dialog box error when loading the zwave driver for the first time?

I did. I tried to replicate but couldn't. It was too late to dig into it for this release, and no one else was seeing it. So we can look at it for a followup release. Does it do it every time after starting the AI, but never again during a given run of the AI?


RE: Official 5.4 Beta Discussion Thread - Dean Roddey - 07-05-2018

(07-05-2018, 03:24 PM)batwater Wrote: The WADWAZ-1 is the type I tried to set manually and it didn't work.  Data fields don't update after being approved.

BTW, does that guy have any configuration options which control what it sends out when tripped?


RE: Official 5.4 Beta Discussion Thread - Dean Roddey - 07-05-2018

OK, yeh, the action editor is whacked for me as well. It's obviously doing something wrong on the initial sizing to fit, not taking into account that the size may be different from the original dialog contents. I'll get that fixed for the followup.