Charmed Quark Systems, Ltd. - Support Forums and Community
cqc server access and webriva - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (
+-- Forum: General Discussion (
+--- Forum: CQC Support (
+--- Thread: cqc server access and webriva (/showthread.php?tid=10454)

Pages: 1 2 3

cqc server access and webriva - zane - 12-22-2017

Hi all

i currently have cqc master server loaded on my server 2012 r2.  how do i access cqc remotly? if im thinking right i need to get this working before getting webriva to work? i tried ip address to port 80 but just takes me to remote server screen.

thank you

RE: cqc server access and webriva - Dean Roddey - 12-22-2017

If you mean from outside the house you will need to expose a port through your router. It also means you need either a static public IP or you need to use a dynamic DNS service. Also, since you don't want to use a non-secure connection, you will really need to use a DDNS service, then buy a security certificate for your DNS name, and install that on your home server, and set up our web server to use it.

Then you would expose a secure port (usually 443, though you can change that) and you would use that to access the web server from outside the house and use port 80 to access from inside the house.

If you go to the /Tools/ section of the help and then the WebRIVA section, there's discussion of this stuff and it'll point you to the section on secure certificates (though that help was added in the last CQC version, so it might not be there if you are not on 5.2.x.)

RE: cqc server access and webriva - zane - 12-22-2017


Im just trying to get it all within my network first. then ill work on access from outside the house. sorry if i said it wrong earlier.

RE: cqc server access and webriva - Dean Roddey - 12-22-2017

When you say remote server screen, what do you mean?

If you mean you saw a page from some other web server, it means that something else is using port 80 and so the CQC web server is locked out. If that's the case you'll have to run the installer again, turn off use previous settings, step over to the web server page and change the port. 8080 is a common one. Then just include that port in the URL explicitly so that it uses that instead of the default 80.

RE: cqc server access and webriva - zane - 12-23-2017

when i try either of the following url:

all i get is a screen the says "connecting to CQC" the screen just stays there. I did create a user and password and assigned a defualt screen which is family then main

thank you

RE: cqc server access and webriva - Dean Roddey - 12-23-2017

Well, the first URL would only work if you actually set up our web server to use 8080. If you haven't then that's not going to do you any good. The second would only work if our web server is able to open port 80. If something else has port 80, then it's not going to work.

First just use a browser. Put a jpeg file in [cqc]\CQCData\HTMLRoot on that gameserver machine. Then try to do:


or whatever the image name is. If you don't get that image, then you aren't getting to our server. If you get some error message, it may be from something else that is using port 80. In which case you can either stop that from running, or move our server to 8080 or something else.

RE: cqc server access and webriva - zane - 12-23-2017


i forgot to mention that the help docs wouldnt pull up from Admin interface. i had to copy the web2 folder to c drive program data/windows server/bin/webapps/site.
then it did work from the admin interface. so i copied the CQSL folder to the same location as the web2 folder.
CQC installed to the default location under program data (86)

i did try the jpeg like you said previously but it only worked from c drive program data/windows server/bin/webapps/site
i did reload the cqc and set the web server to port 8080

RE: cqc server access and webriva - Dean Roddey - 12-23-2017

If you had to copy them there, then there's another web server using port 80. If you re-ran the installer and set it to port 8080, then you should be able to see the image with:


If you don't then something else is wrong.

RE: cqc server access and webriva - EST - 12-24-2017

Zane...are you on the latest version? Had the same issue on the early release version of WebRIVA. Had to add: &tarport=[port] to the address. This is no longer needed on newer releases. If you're at the Connecting to CQC screen then you are at the WebRIVA, just have to find out what the issue is.

RE: cqc server access and webriva - znelbok - 12-24-2017

When you get the Connecting To CQC that would indicate that you have the right url and port. The fact it doesn't load up the interface could mean that there is an error int he username and/or password or you have not assigned a default interface to the user. its not a Web interface that is required just the Default Template (This has apparently caught a few out).

You should be able to load up the IV on a PC with that user and it loads up the template immediately. If it doesn't then that's the problem. I have had the WebRIVA stuff not work with certain templates but can;t isolate what is causing that issue. Just go back to a simple widget on a screen as a way of checking that the URL is right.