Charmed Quark Systems, Ltd. - Support Forums and Community
Venstar Thermostat keeps disconnecting then reconnecting - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (http://www.charmedquark.com/vb_forum)
+-- Forum: General Discussion (http://www.charmedquark.com/vb_forum/forumdisplay.php?fid=3)
+--- Forum: CQC Support (http://www.charmedquark.com/vb_forum/forumdisplay.php?fid=9)
+--- Thread: Venstar Thermostat keeps disconnecting then reconnecting (/showthread.php?tid=10423)



Venstar Thermostat keeps disconnecting then reconnecting - adamalli - 11-06-2017

I seem to be having a problem with the venstar thermostat driver. I have two thermostats, one voyager (thermostat_downstairs) and one color touch(thermostat_upstairs). I have them both loaded in CQC version 5.2.1. This evening the Thermostat_upstairs won't stay connected for more than a 10 seconds and then disconnects and keeps trying to reconnect, the downstairs_thermostat will stay connected and periodically disconnect but is able to reestablish its connection(It goes through that cycle about once every 5 minutes). I am not sure why either driver can't keep its connection. The error log shows that
Code:
CQCKit, MEng.System.CQC.Drivers.Venstar.ColorTouch.DriverImpl.206, Status/App Status
   HTTP GET failed. URL=, Err=Connect operation failed. Tried to connect to: 10.0.0.26:80. The provided value was invalid
but I am able to load that address in my web browser repeatable with no problems.

Any help would be appreciated.

Adam


RE: Venstar Thermostat keeps disconnecting then reconnecting - Dean Roddey - 11-06-2017

Unfortunately the code logging the error is not correct. It's showing an empty URL because it's logging the wrong thing. I've attached another one for you to try so that we can see what the actual URL is. 

Import this package, then do a reconfigure on the driver (at least the one that's failing the one wouldn't matter) and get another log dump after it's run for 30 seconds or so. Let's see what the URL is. The error is from the actual GET operation, and it's a GET so the URL is the only thing involved. So presumably it has to be the URL that's the issue.


RE: Venstar Thermostat keeps disconnecting then reconnecting - adamalli - 11-11-2017

Here is the updated log file. I also reset power to the thermostats and that seems to have cut down on the driver disconnects but they seem to still randomly disconnect.


RE: Venstar Thermostat keeps disconnecting then reconnecting - Dean Roddey - 11-11-2017

Try the attached driver pack. I've lowered the frequency of polling and extended the timeout. Let's see if that makes it happier. Import the driver pack then do a reconfigure on the driver to pick up the changes.