Charmed Quark Systems, Ltd. - Support Forums and Community

Full Version: Windows 10 1803 and TTS problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Thanks to our benevolent overlords, my CQC master server updated itself to Windows 10 1803 this week.  Ever since the update, TTS stopped working in CQC.  The speakers work, and if I use the control panel for speech settings, I do hear spoken text.

I tried the basic things like changing the speaker settings to disable enhancements and unchecked allowing applications to take exclusive control with no change.  I originally tried reconfiguring the driver, and then removed and reinstalled it.

This machine is a VM that just runs CQC and the Brultech ECM software.

Is anyone else on 1803 using TTS successfully?

Here are the errors from the CQC logs.

05/27 11:04:00-hal, CQCServer, WMPAudioPlayerThread_1
    CQCMedia, CQCMedia_WMPAudioPlayer.cpp.1060, Failed/Cannot Do, Error: 5910/0/0
    Could not build the filter graph for file 'C:\Program Files (x86)\CQC\CQCData\Server\Data\CQSLSpeech\tts_hal\CQSLS_TTSData3.wav'
    DirectShow error: 80040256
      <CQCServer> CQCMedia_WMPAudioPlayer.cpp - 1096

05/27 11:04:00-hal, CQCServer, WMPAudioPlayerThread_1
    CQCMedia, CQCMedia_WMPAudioPlayer.cpp.841, Failed/App Status
    An exception occured in the audio player processing loop, restarting loop
05/27 11:04:00-hal, CQCServer, CQCDrv_tts_halThread7
    CQSLSpeechS, CQSLSpeechS_DriverImpl.cpp.580, Failed/Cannot Do
    An error occuring trying to play speech output file
    C:\Program Files (x86)\CQC\CQCData\Server\Data\CQSLSpeech\tts_hal\CQSLS_TTSData3.wav
Do you have the CQC App Shell service logging in under a regular admin account? If not, that's possibly the deal, and it's being prevented by security. Create a new admin account (CQCService or some such name) and set up the CQC App Shell service to log in using that. You'll need to restart the service to pick that up. See if that makes it happy.

The actual error means no hardware or hardware not supported. So I guess it's possible that the driver for the audio hardware is now out of date or something. You may need to update VM software perhaps, which is occasionally necessary after a major OS upgrade. But it's also possible that that's really a side effect of security preventing access to the DirectShow filter graph.
CQC App Shell is running under the local system account. The speakers a Logitech USB model that is mapped directly to the physical device and reflected an updated driver from April. I told Windows to roll back to the previous version which fixed things and have set the connection as metered to hopefully avoid the update happening again.
The local system account probably won't work. At some point everyone seems to go over some security hump and things like access to the filter graph and such stop working under that default account. You usually have to set up a separate account for CQC and let it log in using that. Then it works because it's running under a regular user account.
At the time this happened, I was really busy and just needed to get things back to normal.

To close the loop, this week, I had time to reapply the Windows update, have TTS get unhappy again, and then fix it by creating a separate admin account for CQC's service.
I'm not sure why these increased levels of security tend to get applied to different folk's systems at different points in time. You'd think that it would go out in some regular update and everyone would see it. But it's been sort of straggling into different system over the last couple years at least, maybe longer.